Flip - Services Impacted
Incident Report for Flip
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 16:57 UTC
Update
We are continuing to investigate this issue.
Posted Apr 18, 2024 - 16:46 UTC
Investigating
We are aware of an issue preventing users from accessing Flip. Our team is working hard to remediate and will post an update here as soon as possible. Thank you for your patience and thank you for being part of this community. 💖
Posted Apr 18, 2024 - 16:45 UTC
This incident affected: Educator Dashboard, Student/Guest Videos - Web Browser, Student/Guest Videos - iOS app, and Student/Guest Videos - Android App.